spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Graves (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-20391) Properly rename the memory related fields in ExecutorSummary REST API
Date Wed, 19 Apr 2017 17:18:41 GMT

    [ https://issues.apache.org/jira/browse/SPARK-20391?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15975115#comment-15975115
] 

Thomas Graves commented on SPARK-20391:
---------------------------------------

> My proposal was to add 2 extra fields which duplicate the existing ones, so that the
memory metrics are together and hopefully the meaning is clear. totalManagedMemory would be
the same as maxMemory; usedStorageMemory would be the same as memoryUsed. But I'm not super
firm on that, and its definitely not "must do" for 2.2.

yep, makes sense I would think it is easy enough to do, we should just do it here.

> Properly rename the memory related fields in ExecutorSummary REST API
> ---------------------------------------------------------------------
>
>                 Key: SPARK-20391
>                 URL: https://issues.apache.org/jira/browse/SPARK-20391
>             Project: Spark
>          Issue Type: Improvement
>          Components: Spark Core
>    Affects Versions: 2.2.0
>            Reporter: Saisai Shao
>            Priority: Blocker
>
> Currently in Spark we could get executor summary through REST API {{/api/v1/applications/<app-id>/executors}}.
The format of executor summary is:
> {code}
> class ExecutorSummary private[spark](
>     val id: String,
>     val hostPort: String,
>     val isActive: Boolean,
>     val rddBlocks: Int,
>     val memoryUsed: Long,
>     val diskUsed: Long,
>     val totalCores: Int,
>     val maxTasks: Int,
>     val activeTasks: Int,
>     val failedTasks: Int,
>     val completedTasks: Int,
>     val totalTasks: Int,
>     val totalDuration: Long,
>     val totalGCTime: Long,
>     val totalInputBytes: Long,
>     val totalShuffleRead: Long,
>     val totalShuffleWrite: Long,
>     val isBlacklisted: Boolean,
>     val maxMemory: Long,
>     val executorLogs: Map[String, String],
>     val onHeapMemoryUsed: Option[Long],
>     val offHeapMemoryUsed: Option[Long],
>     val maxOnHeapMemory: Option[Long],
>     val maxOffHeapMemory: Option[Long])
> {code}
> Here are 6 memory related fields: {{memoryUsed}}, {{maxMemory}}, {{onHeapMemoryUsed}},
{{offHeapMemoryUsed}}, {{maxOnHeapMemory}}, {{maxOffHeapMemory}}.
> These all 6 fields reflects the *storage* memory usage in Spark, but from the name of
this 6 fields, user doesn't really know it is referring to *storage* memory or the total memory
(storage memory + execution memory). This will be misleading.
> So I think we should properly rename these fields to reflect their real meanings. Or
we should will document it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message