spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maciej Szymkiewicz (JIRA)" <>
Subject [jira] [Created] (SPARK-19899) FPGrowth input column naming
Date Fri, 10 Mar 2017 12:32:04 GMT
Maciej Szymkiewicz created SPARK-19899:

             Summary: FPGrowth input column naming
                 Key: SPARK-19899
             Project: Spark
          Issue Type: Improvement
          Components: ML
    Affects Versions: 2.2.0
            Reporter: Maciej Szymkiewicz

Current implementation extends {{HasFeaturesCol}}. Personally I find it rather unfortunate.
Up to these moment we used consistent conventions - if we mix-in  {{HasFeaturesCol}} the {{featuresCol}}
should be {{VectorUDT}}. 

Using the same {{Param}} for an {{array<T>}} (and possibly for {{array<arrray<T>>}}
once {{PrefixSpan}} is ported to {{ml}}) will be confusing for the users.

I would like to suggest adding new {{trait}} (let's say {{HasTransactionsCol}}) to clearly
indicate that the input type differs for the other {{Estiamtors}}.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message