spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gopal Nagar (JIRA)" <>
Subject [jira] [Reopened] (SPARK-18804) Join doesn't work in Spark on Bigger tables
Date Tue, 13 Dec 2016 05:43:58 GMT


Gopal Nagar reopened SPARK-18804:

Apologies for marking this JIRA as bug. This may not be a bug in Spark. But i wanted to get
some input on How to make effective join ? Bcoz in my case, job fails despite having enough

> Join doesn't work in Spark on Bigger tables
> -------------------------------------------
>                 Key: SPARK-18804
>                 URL:
>             Project: Spark
>          Issue Type: Question
>          Components: Input/Output
>    Affects Versions: 1.6.1
>            Reporter: Gopal Nagar
> Hi All,
> Spark1.6.1 has been installed on a AWS EMR 3 node cluster which has 32 GB RAM and 80
GB storage each node. I am trying to join two tables (1.2 GB & 900 MB ) have rows 4607818
& 14273378 respectively. It's running in client mode on Yarn cluster manager.
> If i put the limit as 100 in select query it works fine. But if i try to join on entire
data set, Query runs for 3-4 hours and finally gets terminated. I can see always 18 GB free
on each nodes.
> I have tried increasing no of executers/cores/partitions. But still doesn't work. This
has been tried in PySpark and submitted using Spark Submit command but doesn't run. Please
> Join Query 
> --------------
> select * FROM table1 as t1 join table2 as t2 on t1.col = t2.col limit 100;

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message