spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yun Ni (JIRA)" <>
Subject [jira] [Created] (SPARK-18408) API Improvements for LSH
Date Thu, 10 Nov 2016 22:57:58 GMT
Yun Ni created SPARK-18408:

             Summary: API Improvements for LSH
                 Key: SPARK-18408
             Project: Spark
          Issue Type: Improvement
            Reporter: Yun Ni

As the first improvements to current LSH Implementations, we are planning to do the followings:
 - Change output schema to `Array of Vector` instead of `Vectors`
 - Use `numHashTables` as the dimension of `Array` and `numHashFunctions` as the dimension
of `Vector`
 - Rename `RandomProjection` to `BucketedRandomProjectionLSH`, `MinHash` to `MinHashLSH`
 - Make randUnitVectors/randCoefficients private

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message