spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Herman van Hovell (JIRA)" <>
Subject [jira] [Created] (SPARK-17084) Rename ParserUtils.assert to require
Date Tue, 16 Aug 2016 12:37:22 GMT
Herman van Hovell created SPARK-17084:

             Summary: Rename ParserUtils.assert to require
                 Key: SPARK-17084
             Project: Spark
          Issue Type: Improvement
          Components: SQL
    Affects Versions: 2.0.1, 2.1.0
            Reporter: Herman van Hovell
            Assignee: Herman van Hovell
            Priority: Minor

We currently have an assert method in ParserUtils. This is, however, not used as an assert
(a failed assert meaning that the program has reached an invalid state) but is used to check
requirements. I propose to rename this method to {{require}}

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message