spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joseph K. Bradley (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (SPARK-14662) LinearRegressionModel uses only default parameters if yStd is 0
Date Mon, 29 Aug 2016 21:36:22 GMT

     [ https://issues.apache.org/jira/browse/SPARK-14662?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Joseph K. Bradley resolved SPARK-14662.
---------------------------------------
       Resolution: Fixed
         Assignee: Yanbo Liang
    Fix Version/s: 2.0.0

This has now been solved in [SPARK-15339]

> LinearRegressionModel uses only default parameters if yStd is 0
> ---------------------------------------------------------------
>
>                 Key: SPARK-14662
>                 URL: https://issues.apache.org/jira/browse/SPARK-14662
>             Project: Spark
>          Issue Type: Bug
>          Components: ML
>            Reporter: Louis Traynard
>            Assignee: Yanbo Liang
>            Priority: Minor
>             Fix For: 2.0.0
>
>   Original Estimate: 5m
>  Remaining Estimate: 5m
>
> In the (rare) case when yStd is 0 in LinearRegression, parameters are not copied immediately
to the created LinearRegressionModel instance. But they should (as in all other cases), because
currently only the default column names are used in and returned by model.findSummaryModelAndPredictionCol(),
which leads to schema validation errors.
> The fix is two lines and should not be hard to check & apply.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message