spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Reynold Xin (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SPARK-15728) Rename aggregator operators: HashAggregate and SortAggregate
Date Thu, 02 Jun 2016 07:55:59 GMT

     [ https://issues.apache.org/jira/browse/SPARK-15728?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Reynold Xin updated SPARK-15728:
--------------------------------
    Description: 
We currently have two physical aggregate operators: TungstenAggregate and SortBasedAggregate.
These names don't make a lot of sense from an end-user point of view.

Names that would make more sense to end users are HashAggregate and SortAggregate.

  was:
We currently have two physical aggregate operators: TungstenAggregate and SortBasedAggregate.
These names don't make a lot of sense.

Names that would make more sense to end users are HashAggregate and SortAggregate.


> Rename aggregator operators: HashAggregate and SortAggregate
> ------------------------------------------------------------
>
>                 Key: SPARK-15728
>                 URL: https://issues.apache.org/jira/browse/SPARK-15728
>             Project: Spark
>          Issue Type: Sub-task
>          Components: SQL
>            Reporter: Reynold Xin
>            Assignee: Reynold Xin
>
> We currently have two physical aggregate operators: TungstenAggregate and SortBasedAggregate.
These names don't make a lot of sense from an end-user point of view.
> Names that would make more sense to end users are HashAggregate and SortAggregate.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message