spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Apache Spark (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-15525) Clean sbt build fails to resolve sbt-antlr4 plugin
Date Wed, 25 May 2016 17:42:12 GMT

    [ https://issues.apache.org/jira/browse/SPARK-15525?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15300496#comment-15300496
] 

Apache Spark commented on SPARK-15525:
--------------------------------------

User 'hvanhovell' has created a pull request for this issue:
https://github.com/apache/spark/pull/13299

> Clean sbt build fails to resolve sbt-antlr4 plugin
> --------------------------------------------------
>
>                 Key: SPARK-15525
>                 URL: https://issues.apache.org/jira/browse/SPARK-15525
>             Project: Spark
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 2.0.0
>            Reporter: Nick Pentreath
>
> sbt-antlr4 plugin repo page is no longer available, and has been moved to bintray (refer
[here|https://github.com/ihji/sbt-antlr4/commit/77e8f74457e17adad25293720b84ea706deb27f7]).
> This causes building from scratch using sbt to fail to resolve, e.g. 
> {code}
> [info] Resolving com.simplytyped#sbt-antlr4;0.7.10 ...
> [warn]  module not found: com.simplytyped#sbt-antlr4;0.7.10
> [warn] ==== typesafe-ivy-releases: tried
> [warn]   https://repo.typesafe.com/typesafe/ivy-releases/com.simplytyped/sbt-antlr4/scala_2.10/sbt_0.13/0.7.10/ivys/ivy.xml
> [warn] ==== sbt-plugin-releases: tried
> [warn]   https://repo.scala-sbt.org/scalasbt/sbt-plugin-releases/com.simplytyped/sbt-antlr4/scala_2.10/sbt_0.13/0.7.10/ivys/ivy.xml
> [warn] ==== local: tried
> [warn]   /home/npentreath/.ivy2/local/com.simplytyped/sbt-antlr4/scala_2.10/sbt_0.13/0.7.10/ivys/ivy.xml
> [warn] ==== public: tried
> [warn]   https://repo1.maven.org/maven2/com/simplytyped/sbt-antlr4_2.10_0.13/0.7.10/sbt-antlr4-0.7.10.pom
> [warn] ==== simplytyped: tried
> [warn]   http://simplytyped.github.io/repo/releases/com/simplytyped/sbt-antlr4_2.10_0.13/0.7.10/sbt-antlr4-0.7.10.pom
> [info] Resolving org.fusesource.jansi#jansi;1.4 ...
> [warn]  ::::::::::::::::::::::::::::::::::::::::::::::
> [warn]  ::          UNRESOLVED DEPENDENCIES         ::
> [warn]  ::::::::::::::::::::::::::::::::::::::::::::::
> [warn]  :: com.simplytyped#sbt-antlr4;0.7.10: not found
> [warn]  ::::::::::::::::::::::::::::::::::::::::::::::
> [warn]
> [warn]  Note: Some unresolved dependencies have extra attributes.  Check that these dependencies
exist with the requested attributes.
> [warn]          com.simplytyped:sbt-antlr4:0.7.10 (scalaVersion=2.10, sbtVersion=0.13)
> [warn]
> [warn]  Note: Unresolved dependencies path:
> [warn]          com.simplytyped:sbt-antlr4:0.7.10 (scalaVersion=2.10, sbtVersion=0.13)
(/home/npentreath/spark/project/plugins.sbt#L26-27)
> [warn]            +- plugins:plugins:0.1-SNAPSHOT (scalaVersion=2.10, sbtVersion=0.13)
> sbt.ResolveException: unresolved dependency: com.simplytyped#sbt-antlr4;0.7.10: not found
> {code}
> Unfortunately, it also appears the older artefacts have been removed from the github.io
repo (refer [here|https://github.com/simplytyped/simplytyped.github.io/commit/986efba2e3ec75fa4313275496868cbe9fcfc95b],
but not added to bintray, so changing the resolver doesn't help:
> {code}
> info] Resolving com.simplytyped#sbt-antlr4;0.7.10 ...
> [warn]  module not found: com.simplytyped#sbt-antlr4;0.7.10
> [warn] ==== typesafe-ivy-releases: tried
> [warn]   https://repo.typesafe.com/typesafe/ivy-releases/com.simplytyped/sbt-antlr4/scala_2.10/sbt_0.13/0.7.10/ivys/ivy.xml
> [warn] ==== sbt-plugin-releases: tried
> [warn]   https://repo.scala-sbt.org/scalasbt/sbt-plugin-releases/com.simplytyped/sbt-antlr4/scala_2.10/sbt_0.13/0.7.10/ivys/ivy.xml
> [warn] ==== local: tried
> [warn]   /home/npentreath/.ivy2/local/com.simplytyped/sbt-antlr4/scala_2.10/sbt_0.13/0.7.10/ivys/ivy.xml
> [warn] ==== public: tried
> [warn]   https://repo1.maven.org/maven2/com/simplytyped/sbt-antlr4_2.10_0.13/0.7.10/sbt-antlr4-0.7.10.pom
> [warn] ==== bintray-simplytyped: tried
> [warn]   http://dl.bintray.com/simplytyped/sbt-plugins/com.simplytyped/sbt-antlr4/scala_2.10/sbt_0.13/0.7.10/ivys/ivy.xml
> [info] Resolving org.fusesource.jansi#jansi;1.4 ...
> [warn]  ::::::::::::::::::::::::::::::::::::::::::::::
> [warn]  ::          UNRESOLVED DEPENDENCIES         ::
> [warn]  ::::::::::::::::::::::::::::::::::::::::::::::
> [warn]  :: com.simplytyped#sbt-antlr4;0.7.10: not found
> [warn]  ::::::::::::::::::::::::::::::::::::::::::::::
> [warn]
> [warn]  Note: Some unresolved dependencies have extra attributes.  Check that these dependencies
exist with the requested attributes.
> [warn]          com.simplytyped:sbt-antlr4:0.7.10 (scalaVersion=2.10, sbtVersion=0.13)
> [warn]
> [warn]  Note: Unresolved dependencies path:
> [warn]          com.simplytyped:sbt-antlr4:0.7.10 (scalaVersion=2.10, sbtVersion=0.13)
(/home/npentreath/spark/project/plugins.sbt#L26-27)
> [warn]            +- plugins:plugins:0.1-SNAPSHOT (scalaVersion=2.10, sbtVersion=0.13)
> sbt.ResolveException: unresolved dependency: com.simplytyped#sbt-antlr4;0.7.10: not found
> {code}
> I've [commented|https://github.com/ihji/sbt-antlr4/commit/77e8f74457e17adad25293720b84ea706deb27f7#commitcomment-17611397]
on the relevant commit to ask the author to publish the older artefacts to bintray, in which
case we can update the resolver in {{plugins.sbt}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message