spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Weichen Xu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SPARK-15461) modify python test script using default version 2.7
Date Sat, 21 May 2016 06:28:12 GMT

     [ https://issues.apache.org/jira/browse/SPARK-15461?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Weichen Xu updated SPARK-15461:
-------------------------------
    Priority: Major  (was: Critical)

> modify python test script using default version 2.7
> ---------------------------------------------------
>
>                 Key: SPARK-15461
>                 URL: https://issues.apache.org/jira/browse/SPARK-15461
>             Project: Spark
>          Issue Type: Bug
>          Components: PySpark, Tests
>    Affects Versions: 2.0.0
>            Reporter: Weichen Xu
>
> To Spark 2.0, the python test script do not support python 2.6, so need to update the
default python version used in pytion/run_tests.py to python 2.7.
> if using python 2.6, throw error such as:
> [root@n131 spark]# /usr/bin/python2.6 -u ./python/run-tests.py
> Traceback (most recent call last):
>   File "./python/run-tests.py", line 42, in <module>
>     from sparktestsupport.modules import all_modules  # noqa
>   File "/diskext/mySpark/spark/python/../dev/sparktestsupport/modules.py", line 18, in
<module>
>     from functools import total_ordering
> ImportError: cannot import name total_ordering
> The total_ordering is added in python 2.7.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message