spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Owen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-12650) No means to specify Xmx settings for SparkSubmit in yarn-cluster mode
Date Wed, 06 Jan 2016 16:07:39 GMT

    [ https://issues.apache.org/jira/browse/SPARK-12650?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15085734#comment-15085734
] 

Sean Owen commented on SPARK-12650:
-----------------------------------

Hm, the default heap size in the JVM isn't 8GB is it? I just peeked at my Java 8 and it's
about 512MB. 
Is it that it's picking up some other setting causing it to set a large "-Xmx"? but even that
doesn't make the JVM allocate memory. Is "-Xms" set by something? I know we discussed removing
"-Xms" everywhere for similar reasons.

> No means to specify Xmx settings for SparkSubmit in yarn-cluster mode
> ---------------------------------------------------------------------
>
>                 Key: SPARK-12650
>                 URL: https://issues.apache.org/jira/browse/SPARK-12650
>             Project: Spark
>          Issue Type: Bug
>          Components: Spark Submit
>    Affects Versions: 1.5.2
>         Environment: Hadoop 2.6.0
>            Reporter: John Vines
>
> Background-
> I have an app master designed to do some work and then launch a spark job.
> Issue-
> If I use yarn-cluster, then the SparkSubmit does not Xmx itself at all, leading to the
jvm taking a default heap which is relatively large. This causes a large amount of vmem to
be taken, so that it is killed by yarn. This can be worked around by disabling Yarn's vmem
check, but that is a hack.
> If I run it in yarn-client mode, it's fine as long as my container has enough space for
the driver, which is manageable. But I feel that the utter lack of Xmx settings for what I
believe is a very small jvm is a problem.
> I believe this was introduced with the fix for SPARK-3884



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message