spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kousuke Saruta (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-12502) Script /dev/run-tests fails when IBM Java is used
Date Mon, 28 Dec 2015 09:31:49 GMT

    [ https://issues.apache.org/jira/browse/SPARK-12502?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15072565#comment-15072565
] 

Kousuke Saruta commented on SPARK-12502:
----------------------------------------

Oh, [~srowen] has already modified the Fix Version/s from 1.6.0 to 1.6.1. Thanks.

> Script /dev/run-tests fails when IBM Java is used
> -------------------------------------------------
>
>                 Key: SPARK-12502
>                 URL: https://issues.apache.org/jira/browse/SPARK-12502
>             Project: Spark
>          Issue Type: Bug
>          Components: Tests
>    Affects Versions: 1.5.2
>         Environment: IBM Java
>            Reporter: Kazuaki Ishizaki
>            Assignee: Kazuaki Ishizaki
>            Priority: Minor
>             Fix For: 1.6.1, 2.0.0
>
>
> When execute ./dev/run-tests with IBM Java, an exception occurs.
> This is due to difference of a "java version" format.
> $ JAVA_HOME=~/ibmjava8 ./dev/run-tests
> Traceback (most recent call last):
>   File "run-tests.py", line 571, in <module>
>     main()
>   File "run-tests.py", line 474, in main
>     java_version = determine_java_version(java_exe)
>   File "run-tests.py", line 169, in determine_java_version
>     major = int(match.group(1))
> AttributeError: 'NoneType' object has no attribute 'group'
> $ ~/ibmjava8/bin/java -version
> java version "1.8.0"
> Java(TM) SE Runtime Environment (build pxa6480sr2-20151023_01(SR2))
> IBM J9 VM (build 2.8, JRE 1.8.0 Linux amd64-64 Compressed References 20151019_272764
(JIT enabled, AOT enabled)
> J9VM - R28_Java8_SR2_20151019_2144_B272764
> JIT  - tr.r14.java_20151006_102517.04
> GC   - R28_Java8_SR2_20151019_2144_B272764_CMPRSS
> J9CL - 20151019_272764)
> JCL - 20151022_01 based on Oracle jdk8u65-b17
> $ ~/openjdk8/bin/java -version
> java version "1.8.0_66"
> Java(TM) SE Runtime Environment (build 1.8.0_66-b17)
> Java HotSpot(TM) 64-Bit Server VM (build 25.66-b17, mixed mode)
> $



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message