spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Apache Spark (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (SPARK-10704) Consolidate HashShuffleReader and ShuffleReader and refactor ShuffleManager.getReader()
Date Fri, 18 Sep 2015 19:03:04 GMT

     [ https://issues.apache.org/jira/browse/SPARK-10704?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Apache Spark reassigned SPARK-10704:
------------------------------------

    Assignee: Apache Spark  (was: Josh Rosen)

> Consolidate HashShuffleReader and ShuffleReader and refactor ShuffleManager.getReader()
> ---------------------------------------------------------------------------------------
>
>                 Key: SPARK-10704
>                 URL: https://issues.apache.org/jira/browse/SPARK-10704
>             Project: Spark
>          Issue Type: Sub-task
>          Components: Shuffle
>            Reporter: Josh Rosen
>            Assignee: Apache Spark
>
> The current shuffle code has an interface named ShuffleReader with only one implementation,
HashShuffleReader. This naming is confusing, since the same read path code is used for both
sort- and hash-based shuffle. We should consolidate these classes.
> In addition, there are aspects of ShuffleManager.getReader()'s API which don't make a
lot of sense: it exposes the ability to request a contiguous range of shuffle partitions,
but this feature isn't supported by any ShuffleReader implementations and isn't used anywhere
in the existing code. We should clean this up, too.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message