spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Smiley (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-7195) Can't start spark shell or pyspark in Windows 7
Date Tue, 28 Apr 2015 19:22:06 GMT

    [ https://issues.apache.org/jira/browse/SPARK-7195?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14517826#comment-14517826
] 

Mark Smiley commented on SPARK-7195:
------------------------------------

Sean,

I added my bug as a comment to the old bug and attached my file there.

Can you add PySpark as one of the components involved?  I don't have permission to do that.

Thanks,
Mark



> Can't start spark shell or pyspark in Windows 7
> -----------------------------------------------
>
>                 Key: SPARK-7195
>                 URL: https://issues.apache.org/jira/browse/SPARK-7195
>             Project: Spark
>          Issue Type: Bug
>          Components: PySpark, Spark Shell
>    Affects Versions: 1.3.1
>         Environment: Windows 7, Java 8 (1.8.0_31) or Java 7 (1.7.0_79), Scala 2.11.6,
Python 2.7
>            Reporter: Mark Smiley
>         Attachments: spark_bug.png
>
>
> cd\spark\bin dir
> spark-shell
> yields following error:
> find: 'version': No such file or directory
> else was unexpected at this time
> Same error with 
> spark-shell2.cmd
> PyShell starts but with errors and doesn't work properly once started
> (e.g., can't find sc). Can send screenshot of errors on request.
> Using Spark 1.3.1 for Hadoop 2.6 binary
> Note: Hadoop not installed on machine.
> Scala works by itself, Python works by itself
> Java works fine (I use it all the time)
> Based on another comment, tried Java 7 (1.7.0_79), but it made no difference (same error).
> JAVA_HOME = C:\jdk1.8.0\bin
> C:\jdk1.8.0\bin\;C:\Program Files (x86)\scala\bin;C:\Python27;c:\Rtools\bin;c:\Rtools\gcc-4.6.3\bin;C:\Oracle\product64\12.1.0\client_1\bin;C:\Oracle\product\12.1.0\client_1\bin;C:\ProgramData\Oracle\Java\javapath;C:\Program
Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program
Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management
Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program
Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Dell\Dell Data
Protection\Access\Advanced\Wave\Gemalto\Access Client\v5\;C:\Program Files (x86)\NTRU Cryptosystems\NTRU
TCG Software Stack\bin\;C:\Program Files\NTRU Cryptosystems\NTRU TCG Software Stack\bin\;C:\Program
Files (x86)\Intel\OpenCL SDK\2.0\bin\x86;C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin\x64;C:\Program
Files\MiKTeX 2.9\miktex\bin\x64\;C:\Program Files (x86)\ActivIdentity\ActivClient\;C:\Program
Files\ActivIdentity\ActivClient\



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message