spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Wendell (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SPARK-2026) Maven "hadoop*" Profiles Should Set the expected Hadoop Version.
Date Sun, 08 Jun 2014 08:27:02 GMT

     [ https://issues.apache.org/jira/browse/SPARK-2026?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Patrick Wendell updated SPARK-2026:
-----------------------------------

    Assignee: Bernardo Gomez Palacio

> Maven "hadoop*" Profiles Should Set the expected Hadoop Version.
> ----------------------------------------------------------------
>
>                 Key: SPARK-2026
>                 URL: https://issues.apache.org/jira/browse/SPARK-2026
>             Project: Spark
>          Issue Type: Improvement
>          Components: Build
>    Affects Versions: 1.0.0
>            Reporter: Bernardo Gomez Palacio
>            Assignee: Bernardo Gomez Palacio
>             Fix For: 1.1.0
>
>
> The Maven Profiles that refer to _hadoopX_, e.g. hadoop2.4, should set the expected _hadoop.version_.
> e.g.
> {code}
> <profile>
>       <id>hadoop-2.4</id>
>       <properties>
>         <protobuf.version>2.5.0</protobuf.version>
>         <jets3t.version>0.9.0</jets3t.version>
>       </properties>
> </profile>
> {code}
> as it is suggested
> {code}
> <profile>
>       <id>hadoop-2.4</id>
>       <properties>
>         <hadoop.version>2.4.0</hadoop.version>
>          <yarn.version>${hadoop.version}</yarn.version>
>         <protobuf.version>2.5.0</protobuf.version>
>         <jets3t.version>0.9.0</jets3t.version>
>       </properties>
> </profile>
> {code}
> Builds can still define the -Dhadoop.version option but this will correctly default the
Hadoop Version to the one that is expected according the profile that is selected.
> e.g.
> {code}
> $ mvn -P hadoop-2.4,yarn clean compile
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message