spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yin Huai (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-1935) Explicitly add commons-codec 1.5 as a dependency
Date Tue, 27 May 2014 20:41:03 GMT

    [ https://issues.apache.org/jira/browse/SPARK-1935?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14010241#comment-14010241
] 

Yin Huai commented on SPARK-1935:
---------------------------------

I have updated my PR to use codec 1.5.

> Explicitly add commons-codec 1.5 as a dependency
> ------------------------------------------------
>
>                 Key: SPARK-1935
>                 URL: https://issues.apache.org/jira/browse/SPARK-1935
>             Project: Spark
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 0.9.1
>            Reporter: Yin Huai
>            Assignee: Yin Huai
>            Priority: Minor
>
> Right now, commons-codec is a transitive dependency. When Spark is built by maven for
Hadoop 1, jets3t 0.7.1 will pull in commons-codec 1.3 which is an older version (Hadoop 1.0.4
depends on 1.4). This older version can cause problems because 1.4 introduces incompatible
changes and new methods.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message