spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Owen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-1378) Build error: org.eclipse.paho:mqtt-client
Date Tue, 01 Apr 2014 14:26:14 GMT

    [ https://issues.apache.org/jira/browse/SPARK-1378?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13956551#comment-13956551
] 

Sean Owen commented on SPARK-1378:
----------------------------------

In that case, it seemed that it was clearly a proxy issue since adding proxy settings resolved
the problem. That much is fine but not something to put in the general build. It also wouldn't
help to add another repo... er, well, it's better to simply configure for access to the standard
repos.

Try building the examples module (that's where it fails right?) with "-X" to output a lot
more debug info. It is probably saying in there somewhere why it can't access the repos, and
there may be a clue there. For example do you have anything that would proxy an HTTPS connection?
that could break access.

Also use "-U" to make sure it is not caching lookup failures from previous runs.

If you have a home machine or can try from home that might also rule out network issues.

> Build error: org.eclipse.paho:mqtt-client
> -----------------------------------------
>
>                 Key: SPARK-1378
>                 URL: https://issues.apache.org/jira/browse/SPARK-1378
>             Project: Spark
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 0.9.0
>            Reporter: Ken Williams
>
> Using Maven, I'm unable to build the 0.9.0 distribution I just downloaded. I attempt
like so:
> {code}
> mvn -U -Pyarn -Dhadoop.version=2.2.0 -Dyarn.version=2.2.0 -DskipTests package
> {code}
> The Maven error is:
> {code}
> [ERROR] Failed to execute goal on project spark-examples_2.10: Could not resolve dependencies
for project org.apache.spark:spark-examples_2.10:jar:0.9.0-incubating: Could not find artifact
org.eclipse.paho:mqtt-client:jar:0.4.0 in nexus
> {code}
> My Maven version is 3.2.1, running on Java 1.7.0, using Scala 2.10.4.
> Is there an additional Maven repository I should add or something?
> If I go into the {{pom.xml}} and comment out the {{external/mqtt}} and {{examples}} modules,
the build succeeds. I'm fine without the MQTT stuff, but I would really like to get the examples
working because I haven't played with Spark before.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message