spark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Preece <tepre...@mail.com>
Subject Re: [VOTE] Release Apache Spark 1.6.1 (RC1)
Date Thu, 03 Mar 2016 11:00:21 GMT
I have been testing 1.6.1RC1 using the IBM Java SDK.

I notice a problem ( with the org.apache.spark.sql.hive.client.VersionsSuite
tests ) after a recent Spark 1.6.1 change. 
Pull request -
https://github.com/apache/spark/commit/f7898f9e2df131fa78200f6034508e74a78c2a44

The change introduced a dependency on
org.apache.hadoop.hive.cli.CliSessionState in
org.apache.spark.sql.hive.client.ClientWrapper. 

In particular the following test was added
if (originalState.isInstanceOf[CliSessionState]) {

The problem is that VersionsSuite test uses an isolated classloader in order
to test various versions of Hive. However the classpath of the isolated
classloader does not contain CliSessionState. 

The behaviour of isInstanceOf[CliSessionState]) is JVM vendor specific. In
particular whether this code causes the CliSessionState class to be loaded.
( It does not for openjdk, but does for IBM JDK ). Hence this call can throw
a classnotfound exception.

I will have a pull request to fix the testcase very shortly.

I opened JIRA SPARK-13648 ( i wasn't too sure if I should have reopened one
of SPARK-11624 or SPARK-11972 instead ?)

 





--
View this message in context: http://apache-spark-developers-list.1001551.n3.nabble.com/VOTE-Release-Apache-Spark-1-6-1-RC1-tp16532p16537.html
Sent from the Apache Spark Developers List mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@spark.apache.org
For additional commands, e-mail: dev-help@spark.apache.org


Mime
View raw message