spark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Wendell <pwend...@gmail.com>
Subject Re: [discuss] ending support for Java 6?
Date Tue, 05 May 2015 10:08:55 GMT
If there is broad consensus here to drop Java 1.6 in Spark 1.5, should
we do an ANNOUNCE to user and dev?

On Mon, May 4, 2015 at 7:24 PM, shane knapp <sknapp@berkeley.edu> wrote:
> sgtm
>
> On Mon, May 4, 2015 at 11:23 AM, Patrick Wendell <pwendell@gmail.com> wrote:
>>
>> If we just set JAVA_HOME in dev/run-test-jenkins, I think it should work.
>>
>> On Mon, May 4, 2015 at 7:20 PM, shane knapp <sknapp@berkeley.edu> wrote:
>> > ...and now the workers all have java6 installed.
>> >
>> > https://issues.apache.org/jira/browse/SPARK-1437
>> >
>> > sadly, the built-in jenkins jdk management doesn't allow us to choose a
>> > JDK
>> > version within matrix projects...  so we need to manage this stuff
>> > manually.
>> >
>> > On Sun, May 3, 2015 at 8:57 AM, shane knapp <sknapp@berkeley.edu> wrote:
>> >
>> >> that bug predates my time at the amplab...  :)
>> >>
>> >> anyways, just to restate: jenkins currently only builds w/java 7.  if
>> >> you
>> >> folks need 6, i can make it happen, but it will be a (smallish) bit of
>> >> work.
>> >>
>> >> shane
>> >>
>> >> On Sun, May 3, 2015 at 2:14 AM, Sean Owen <sowen@cloudera.com> wrote:
>> >>
>> >>> Should be, but isn't what Jenkins does.
>> >>> https://issues.apache.org/jira/browse/SPARK-1437
>> >>>
>> >>> At this point it might be simpler to just decide that 1.5 will require
>> >>> Java 7 and then the Jenkins setup is correct.
>> >>>
>> >>> (NB: you can also solve this by setting bootclasspath to JDK 6 libs
>> >>> even when using javac 7+ but I think this is overly complicated.)
>> >>>
>> >>> On Sun, May 3, 2015 at 5:52 AM, Mridul Muralidharan <mridul@gmail.com>
>> >>> wrote:
>> >>> > Hi Shane,
>> >>> >
>> >>> >   Since we are still maintaining support for jdk6, jenkins should
be
>> >>> > using jdk6 [1] to ensure we do not inadvertently use jdk7 or higher
>> >>> > api which breaks source level compat.
>> >>> > -source and -target is insufficient to ensure api usage is
>> >>> > conformant
>> >>> > with the minimum jdk version we are supporting.
>> >>> >
>> >>> > Regards,
>> >>> > Mridul
>> >>> >
>> >>> > [1] Not jdk7 as you mentioned
>> >>> >
>> >>> > On Sat, May 2, 2015 at 8:53 PM, shane knapp <sknapp@berkeley.edu>
>> >>> wrote:
>> >>> >> that's kinda what we're doing right now, java 7 is the
>> >>> default/standard on
>> >>> >> our jenkins.
>> >>> >>
>> >>> >> or, i vote we buy a butler's outfit for thomas and have a second
>> >>> jenkins
>> >>> >> instance...  ;)
>> >>>
>> >>
>> >>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@spark.apache.org
For additional commands, e-mail: dev-help@spark.apache.org


Mime
View raw message