spark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Owen <so...@cloudera.com>
Subject Should new YARN shuffle service work with "yarn-alpha"?
Date Sat, 08 Nov 2014 07:43:03 GMT
I noticed that this doesn't compile:

mvn -Pyarn-alpha -Phadoop-0.23 -Dhadoop.version=0.23.7 -DskipTests clean package

[error] warning: [options] bootstrap class path not set in conjunction
with -source 1.6
[error] /Users/srowen/Documents/spark/network/yarn/src/main/java/org/apache/spark/network/yarn/YarnShuffleService.java:26:
error: cannot find symbol
[error] import org.apache.hadoop.yarn.server.api.AuxiliaryService;
[error]                                         ^
[error]   symbol:   class AuxiliaryService
[error]   location: package org.apache.hadoop.yarn.server.api
[error] /Users/srowen/Documents/spark/network/yarn/src/main/java/org/apache/spark/network/yarn/YarnShuffleService.java:27:
error: cannot find symbol
[error] import org.apache.hadoop.yarn.server.api.ApplicationInitializationContext;
[error]                                         ^
...

Should it work? if not shall I propose to enable the service only with -Pyarn?

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@spark.apache.org
For additional commands, e-mail: dev-help@spark.apache.org


Mime
View raw message