spark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matei Zaharia <matei.zaha...@gmail.com>
Subject Re: spark compatibility between releases?
Date Fri, 17 Jan 2014 19:20:36 GMT
Hi Tom,

So far you’ve had to recompile with each release. Between master and 0.8 in particular,
one problem is that the Scala version changed, which will always require a recompile in Scala
programs.

In the future, we want to make minor releases not require a recompile.

Matei

On Jan 17, 2014, at 7:53 AM, Tom Graves <tgraves_cs@yahoo.com> wrote:

> Hey everyone,
> 
> What is the story as far as Spark compatibility between releases?  Are we saying recompile
needed until we get to 1.X type releases?  
> 
> It might be a good idea for us to document our compatibility strategy going forward.

> 
> I had someone say they built against master and tried to run on 0.8 and were getting
errors. (invalid type code: AC - when doing matrix qr)
> 
> Thanks,
> Tom


Mime
View raw message