spark-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sro...@apache.org
Subject spark git commit: [SPARK-15238] Clarify supported Python versions
Date Wed, 11 May 2016 10:00:24 GMT
Repository: spark
Updated Branches:
  refs/heads/branch-2.0 1e7d8ba5d -> 1753f6502


[SPARK-15238] Clarify supported Python versions

This PR:
* Clarifies that Spark *does* support Python 3, starting with Python 3.4.

Author: Nicholas Chammas <nicholas.chammas@gmail.com>

Closes #13017 from nchammas/supported-python-versions.

(cherry picked from commit fafc95af79fa34f82964a86407c2ee046eda3814)
Signed-off-by: Sean Owen <sowen@cloudera.com>


Project: http://git-wip-us.apache.org/repos/asf/spark/repo
Commit: http://git-wip-us.apache.org/repos/asf/spark/commit/1753f650
Tree: http://git-wip-us.apache.org/repos/asf/spark/tree/1753f650
Diff: http://git-wip-us.apache.org/repos/asf/spark/diff/1753f650

Branch: refs/heads/branch-2.0
Commit: 1753f6502ce7c81f43e120b0dc324674b4d5331c
Parents: 1e7d8ba
Author: Nicholas Chammas <nicholas.chammas@gmail.com>
Authored: Wed May 11 11:00:12 2016 +0100
Committer: Sean Owen <sowen@cloudera.com>
Committed: Wed May 11 11:00:20 2016 +0100

----------------------------------------------------------------------
 docs/index.md | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/spark/blob/1753f650/docs/index.md
----------------------------------------------------------------------
diff --git a/docs/index.md b/docs/index.md
index 20eab56..7157afc 100644
--- a/docs/index.md
+++ b/docs/index.md
@@ -24,8 +24,8 @@ Spark runs on both Windows and UNIX-like systems (e.g. Linux, Mac OS). It's
easy
 locally on one machine --- all you need is to have `java` installed on your system `PATH`,
 or the `JAVA_HOME` environment variable pointing to a Java installation.
 
-Spark runs on Java 7+, Python 2.6+ and R 3.1+. For the Scala API, Spark {{site.SPARK_VERSION}}
uses
-Scala {{site.SCALA_BINARY_VERSION}}. You will need to use a compatible Scala version 
+Spark runs on Java 7+, Python 2.6+/3.4+ and R 3.1+. For the Scala API, Spark {{site.SPARK_VERSION}}
+uses Scala {{site.SCALA_BINARY_VERSION}}. You will need to use a compatible Scala version
 ({{site.SCALA_BINARY_VERSION}}.x).
 
 # Running the Examples and Shell


---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@spark.apache.org
For additional commands, e-mail: commits-help@spark.apache.org


Mime
View raw message