spark-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sro...@apache.org
Subject spark git commit: [SPARK-10497] [BUILD] [TRIVIAL] Handle both locations for JIRAError with python-jira
Date Thu, 10 Sep 2015 14:42:18 GMT
Repository: spark
Updated Branches:
  refs/heads/master 1dc7548c5 -> 48817cc11


[SPARK-10497] [BUILD] [TRIVIAL] Handle both locations for JIRAError with python-jira

Location of JIRAError has moved between old and new versions of python-jira package.
Longer term it probably makes sense to pin to specific versions (as mentioned in https://issues.apache.org/jira/browse/SPARK-10498
) but for now, making release tools works with both new and old versions of python-jira.

Author: Holden Karau <holden@pigscanfly.ca>

Closes #8661 from holdenk/SPARK-10497-release-utils-does-not-work-with-new-jira-python.


Project: http://git-wip-us.apache.org/repos/asf/spark/repo
Commit: http://git-wip-us.apache.org/repos/asf/spark/commit/48817cc1
Tree: http://git-wip-us.apache.org/repos/asf/spark/tree/48817cc1
Diff: http://git-wip-us.apache.org/repos/asf/spark/diff/48817cc1

Branch: refs/heads/master
Commit: 48817cc111a9705f40b7c842315eee24291c2198
Parents: 1dc7548
Author: Holden Karau <holden@pigscanfly.ca>
Authored: Thu Sep 10 16:42:12 2015 +0200
Committer: Sean Owen <sowen@cloudera.com>
Committed: Thu Sep 10 16:42:12 2015 +0200

----------------------------------------------------------------------
 dev/create-release/releaseutils.py | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/spark/blob/48817cc1/dev/create-release/releaseutils.py
----------------------------------------------------------------------
diff --git a/dev/create-release/releaseutils.py b/dev/create-release/releaseutils.py
index 51ab25a..7f152b7 100755
--- a/dev/create-release/releaseutils.py
+++ b/dev/create-release/releaseutils.py
@@ -24,7 +24,11 @@ from subprocess import Popen, PIPE
 
 try:
     from jira.client import JIRA
-    from jira.exceptions import JIRAError
+    # Old versions have JIRAError in exceptions package, new (0.5+) in utils.
+    try:
+        from jira.exceptions import JIRAError
+    except ImportError:
+        from jira.utils import JIRAError
 except ImportError:
     print "This tool requires the jira-python library"
     print "Install using 'sudo pip install jira'"


---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@spark.apache.org
For additional commands, e-mail: commits-help@spark.apache.org


Mime
View raw message