spark-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From joshro...@apache.org
Subject spark git commit: [SPARK-6905] Upgrade to snappy-java 1.1.1.7
Date Tue, 14 Apr 2015 20:42:02 GMT
Repository: spark
Updated Branches:
  refs/heads/branch-1.3 2954468b0 -> db2154d7d


[SPARK-6905] Upgrade to snappy-java 1.1.1.7

We should upgrade our snappy-java dependency to 1.1.1.7 in order to include a fix for a bug
that results in worse compression in SnappyOutputStream (see https://github.com/xerial/snappy-java/issues/100).

Author: Josh Rosen <joshrosen@databricks.com>

Closes #5512 from JoshRosen/snappy-1.1.1.7 and squashes the following commits:

f1ac0f8 [Josh Rosen] Upgrade to snappy-java 1.1.1.7.

(cherry picked from commit 6adb8bcbf0a1a7bfe2990de18c59c66cd7a0aeb8)
Signed-off-by: Josh Rosen <joshrosen@databricks.com>

Conflicts:
	pom.xml


Project: http://git-wip-us.apache.org/repos/asf/spark/repo
Commit: http://git-wip-us.apache.org/repos/asf/spark/commit/db2154d7
Tree: http://git-wip-us.apache.org/repos/asf/spark/tree/db2154d7
Diff: http://git-wip-us.apache.org/repos/asf/spark/diff/db2154d7

Branch: refs/heads/branch-1.3
Commit: db2154d7d982c15b63cf6911405ec23a9506a96a
Parents: 2954468
Author: Josh Rosen <joshrosen@databricks.com>
Authored: Tue Apr 14 13:40:07 2015 -0700
Committer: Josh Rosen <joshrosen@databricks.com>
Committed: Tue Apr 14 13:41:50 2015 -0700

----------------------------------------------------------------------
 pom.xml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/spark/blob/db2154d7/pom.xml
----------------------------------------------------------------------
diff --git a/pom.xml b/pom.xml
index a599ad4..5cd21f1 100644
--- a/pom.xml
+++ b/pom.xml
@@ -155,7 +155,7 @@
     <jodd.version>3.6.3</jodd.version>
     <codehaus.jackson.version>1.8.8</codehaus.jackson.version>
     <fasterxml.jackson.version>2.4.4</fasterxml.jackson.version>
-    <snappy.version>1.1.1.6</snappy.version>
+    <snappy.version>1.1.1.7</snappy.version>
 
     <!--
       Dependency scopes that can be overridden by enabling certain profiles. These profiles
are


---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@spark.apache.org
For additional commands, e-mail: commits-help@spark.apache.org


Mime
View raw message