spark-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject [2/2] git commit: Merge pull request #112 from kayousterhout/ui_task_attempt_id
Date Mon, 28 Oct 2013 02:32:13 GMT
Merge pull request #112 from kayousterhout/ui_task_attempt_id

Display both task ID and task attempt ID in UI, and rename taskId to taskAttemptId

Previously only the task attempt ID was shown in the UI; this was confusing because the job
can be shown as complete while there are tasks still running.  Showing the task ID in addition
to the attempt ID makes it clear which tasks are redundant.

This commit also renames taskId to taskAttemptId in TaskInfo and in the local/cluster schedulers.
 This identifier was used to uniquely identify attempts, not tasks, so the current naming
was confusing.  The new naming is also more consistent with map reduce.


Branch: refs/heads/master
Commit: aec9bf90606839a5f8ba58ad72af4fafc9efad76
Parents: d4df474 ae22b4d
Author: Matei Zaharia <>
Authored: Sun Oct 27 19:32:00 2013 -0700
Committer: Matei Zaharia <>
Committed: Sun Oct 27 19:32:00 2013 -0700

 core/src/main/scala/org/apache/spark/ui/jobs/StagePage.scala | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

View raw message