spamassassin-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Giovanni Bechis <giova...@paclan.it>
Subject Re: Warnings when enabling URILocalBL plugin
Date Thu, 08 Nov 2018 22:57:02 GMT
On Thu, Nov 08, 2018 at 01:43:15PM -0600, quinn@strangecode.com wrote:
> So, these warnings may be unrelated to URILocalBL: I disabled that plugin and the errors
are still appearing.
> 
...
> Here is the output from `spamassassin -D --lint`:
> https://pastebin.com/raw/Zr7umPQv
> 
> 	perl-Geo-IP-1.38-1.el6.rf.x86_64
>
it's a bug in RelayCountry.pm that can be triggered only if GeoIP is < 1.39 (without ipv6
support).
It'is fixed in current tree and will be released with 3.4.3.

If you can use country_db_type = Fast/DB_File/GeoIP2 it will work.
I think that only IP-Country-Fast could be available due to the age of the distribution you
are using;
IP-Contry-DB_File can be also easily build using cpan, GeoIP2 requires more modules and I
do not know if it could
be compatible with other modules provided by the distribution you are using.
 Cheers
  Giovanni

Mime
View raw message