spamassassin-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Troy <rt...@ScienceTools.com>
Subject Fedora 21 / Postfix config issue
Date Thu, 16 Apr 2015 17:08:47 GMT



Hello,

After hardware failure, I did an OS upgrade, too, and have a new Fedora 
Core 21 installation with these packages installed:

postfix-2.11.3-1.fc21.x86_64

spamass-milter-0.4.0-1.fc21.x86_64
spamass-milter-postfix-0.4.0-1.fc21.noarch
spamassassin-3.4.0-13.fc21.x86_64

I'm a long-time postfix user, but new to SpamAssassin. Postfix is up and 
running fine. However, there's something missing in the directions about 
how postfix and SpamAssassin get integrated together, and that's my 
primary concern right now. ...I can get SA running, but nothing I've tried 
so far in smtpd_milters has worked (I presume that's how I'm supposed to
get Postfix to talk to SpamAssassin?)

The official fedora-specific directions, I take it, are to be found in 
/usr/share/doc/spamassassin. I've been through that and haven't found 
anything on smtpd_milters, though it's certainly piqued my interest in 
several related topics. ...The README found there cites a document called 
"INSTALL" but that document isn't in my distribution. So, I went to what I 
take to be the official web site documentation and it points me to two 
pages that (for at least the last two days) don't load (namely two links 
to http://www.onetforum.com).

I did a lot of looking around and found /etc/mail/spamassassin which has a 
file, local.cf, which includes a URL to a page entitled, "How to install 
and integrate SpamAssassin with Postfix on a CentOS 6 VPS" but it was 
unhelpful - or, rather, I learned a lot but it didn't help solve the 
issue, again, wrong versions.

Looking elsewhere for help, all the (great many) wonderful directions I 
find on the web appear to be for other distributions OR earlier versions 
of Fedora which don't work the way this version does. So, I'm coming here 
for help - hope this is the right place.

I was confused at the distinction between spamass-milter and spamassassin 
(see installed version notes above), and figured these are cooperating 
packages, all part of SpamAssassin. ...So, I looked into the 
/usr/share/doc/spamass-milter-postfix directory and found a note that I 
should set Postfix's smtpd_milters value to:

  unix:/run/spamass-milter/postfix/sock

However, first of all, while the directory exists, that file (socket) does 
not. I considered making it myself, but there is no mksock on this 
distribution and I'm a little hesitant to use mknod which I vaguely recall 
might be able to do this - could well be wrong.

The non-existence of the socket has me puzzled. In any event, bravely 
continuing on, I just tried to start things up anyway, and postfix starts, 
of course, but gives this error:

postfix/smtpd[18151]: warning: connect to Milter service 
unix:/run/spamass-milter/postfix/sock: No such file or directory

Which, of course, I already knew didn't exist - so, I also see that none 
of the extant, running software decided to create it.

I DO NOTE, however, that there's something called spamd ... I have NOT 
touched it per se; instead, I've started "spamassassin.service" (with 
systemctl) and when I check status, it says:

  spamd[27493]: spamd: server started on IO::Socket::IP [127.0.0.1]:783, 
IO::Socket::IP [::1]:783 (running version 3.4.0)

...This gives the STRONG suggestion I should be putting that socket number 
into postfix's smtpd_milters parameter...

OK, that's where I'm at; help humbly requested.

Regards,
Richard

Mime
View raw message