spamassassin-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Taylor <tim.tay...@gmail.com>
Subject Re: sa-update failing: SHA1 verification failed
Date Wed, 04 Feb 2015 13:46:18 GMT
Hi Mark,

Thanks very much - you were spot on! I had noticed the file there, but
didn't think it was unusual. But I've now deleted the file (along the the
associated .asc and .sha1 files which were also there), and sa-update now
works again.

Many thanks for your help.

On Wed, Feb 4, 2015 at 11:17 AM, Mark Martinec <Mark.Martinec+sa@ijs.si>
wrote:

> Tim Taylor wrote:
>
>> For the last few days (from 31 Jan 2015), sa-update has been failing on my
>> server. I've checked and can't see that any package updates happened
>> around
>> then, so I'm puzzled by why this is happening (it's been working fine for
>> over a year beforehand).
>>
>> I'm running sa-update version svn1475932 (with Perl version 5.18.2) on a
>> 64-bit Ubuntu 14.04 box.
>>
>> Running "sa-update -D" shows the following output:
>>
> [...]
>
>> So the update is not getting the expected sha1 verification. There are 4
>> mirrors in MIRRORED.BY, and I've tested it with each one selected
>> individually and the others removed, but I get the same result for each
>> mirror. I also reinstalled Digest::SHA1 on CPAN, but still no joy.
>>
>> Has anyone else noticed this problem, or is it just me? Any ideas how I
>> can
>> fix this? Is it a problem with my installation or with the mirrors?
>>
>
> Perhaps you have an existing (old or corrupted) file 1655961.tar.gz
> with a timestamp younger than the timestamp of this file on the
> web server, and the -z option in curl is preventing a new file to
> be downloaded.
>
>   Mark
>

Mime
View raw message