spamassassin-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Martinec <Mark.Martinec...@ijs.si>
Subject Re: Mail::SpamAssassin::Plugin::Check::_head_tests_0_1, skipping: Jan 17 08:00:12.091 [2891] warn: (Insecure dependency in require while running with -T switch at (eval 1037) line 9
Date Mon, 19 Jan 2015 17:42:54 GMT
Klaus wrote:
> Thanks. I am running SA version 3.4.0.

> Jan 17 08:00:12.091 [2891] warn: rules: failed to compile
>   Mail::SpamAssassin::Plugin::Check::_head_tests_0_1, skipping:
> Jan 17 08:00:12.091 [2891] warn:  (Insecure dependency in require
>   while running with -T switch at (eval 1037) line 9.

In Mail/SpamAssassin/Plugin/Check.pm near line 453 (version 3.4.0)
(i.e. in sub flush_evalstr) there is a commented-out debug line:

   # dbg("rules: eval code(2): %s", $self->{evalstr});

Try uncommenting it and enable debugging (option '-D rules'
in spamd or in a command-line spamassassin, or '-d rules'
in amavisd). Let's see what was the code that the eval()
was trying to compile.

   Mark

Mime
View raw message