spamassassin-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Hardin <jhar...@impsec.org>
Subject Re: Argument "perl_version" isn't numeric
Date Sun, 30 Nov 2014 22:29:59 GMT
On Sun, 30 Nov 2014, jdow wrote:

>>  On Sun, 30 Nov 2014, Benny Pedersen wrote:
>> >  On 30. nov. 2014 22.15.12 John Hardin <jhardin@impsec.org> wrote:
>> > 
>> > >       if version > 3.004001
>> > >         if perl_version >= 5.010000
>> > >           body NON_588_COMPATIBLE_RE_SYNTAX /\w++/
>> > >         endif
>> > >       endif
>> > 
>> >  If this works now in spamassassin 3.3.2, problem solved, can i send 
>> >  bitcoins
>> >  somewhere ? :)
>>
>>  It "works" in 3.3.2 *IF* you accept the warning about perl_version
>>  being non-numeric that this entire thread is about. The
>>  non-5.8.8-compatible RE is skipped, because the perl_version
>>  conditional fails to false on the type warning and doesn't include the
>>  rule.
>
> Would a corrected syntax version of this work?
>
> if version > 3.004001 && perl_version >= 5.010000
>   body NON_588_COMPATIBLE_RE_SYNTAX /\w++/
> endif

Yes. That *does* work.

Thank you! I think you just solved it.

-- 
  John Hardin KA7OHZ                    http://www.impsec.org/~jhardin/
  jhardin@impsec.org    FALaholic #11174     pgpk -a jhardin@impsec.org
  key: 0xB8732E79 -- 2D8C 34F4 6411 F507 136C  AF76 D822 E6E6 B873 2E79
-----------------------------------------------------------------------
   Activist: Someone who gets involved.
   Unregistered Lobbyist: Someone who gets involved with something
     the MSM doesn't approve of.                           -- WizardPC
-----------------------------------------------------------------------
  15 days until Bill of Rights day

Mime
View raw message