spamassassin-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Herbert J. Skuhra" <hsku...@eumx.net>
Subject Re: Bayer Filter Not Working
Date Tue, 01 Jul 2014 21:05:03 GMT
On Tue, 01 Jul 2014 09:37:17 +0200
Herbert J. Skuhra wrote:

> Den 25.06.2014 00:42, skrev Bruce Sackett:
> > I apologize, I’m sure it’s been covered, but I have not been
> > successful finding results in searches on the web or through the
> > history of the list.  I get no BAYES results in the headers, so I
> > don’t see any working.  The part that gets me is below:
> > 
> > Jun 24 13:47:53.165 [3245] dbg: bayes: tie-ing to DB file R/O
> > /var/lib/amavis/.spamassassin/bayes_toks
> > Jun 24 13:47:53.166 [3245] dbg: bayes: tie-ing to DB file R/O
> > /var/lib/amavis/.spamassassin/bayes_seen
> > Jun 24 13:47:53.167 [3245] dbg: bayes: found bayes db version 3
> > Jun 24 13:47:53.167 [3245] warn: plugin: eval failed: Insecure
> > dependency in sprintf while running with -T switch at
> > /usr/local/share/perl/5.14.2/Mail/SpamAssassin/Logger.pm line 241.
> > Jun 24 13:47:53.168 [3245] dbg: config: score set 0 chosen.
> > 
> > That seems to be the last time Bayes is referenced in a spamassassin
> > -D ―lint
> > 
> > Has anyone else run into this?  I am using an Ubuntu 12.04 server, if
> > that makes any difference.
> 
> I have the same problem on FreeBSD:
> 
> Jul  1 05:33:51.765 [43144] dbg: bayes: learner_new
> self=Mail::SpamAssassin::Plugin::Bayes=HASH(0x805b09f78),
> bayes_store_module=Mail::SpamAssassin::BayesStore::DBM
> Jul  1 05:33:51.778 [43144] dbg: bayes: learner_new: got
> store=Mail::SpamAssassin::BayesStore::DBM=HASH(0x806108798)
> Jul  1 05:33:51.779 [43144] dbg: bayes: tie-ing to DB file R/O
> /var/amavis/.spamassassin/bayes_toks
> Jul  1 05:33:51.779 [43144] dbg: bayes: tie-ing to DB file R/O
> /var/amavis/.spamassassin/bayes_seen
> Jul  1 05:33:51.779 [43144] dbg: bayes: found bayes db version 3
> Jul  1 05:33:51.779 [43144] warn: plugin: eval failed: Insecure
> dependency in sprintf while running with -T switch at
> /usr/local/lib/perl5/site_perl/5.16/Mail/SpamAssassin/Logger.pm line
> 241.
> Jul  1 05:33:51.799 [43144] warn: plugin: eval failed: Insecure
> dependency in sprintf while running with -T switch at
> /usr/local/lib/perl5/site_perl/5.16/Mail/SpamAssassin/Logger.pm line
> 241.
> 
> Running 'sa-learn --force-expire' seems to resolve the issue temporally.
> 
> Jul  1 09:35:06.084 [49647] dbg: bayes: learner_new
> self=Mail::SpamAssassin::Plugin::Bayes=HASH(0x805b09f78),
> bayes_store_module=Mail::SpamAssassin::BayesStore::DBM
> Jul  1 09:35:06.097 [49647] dbg: bayes: learner_new: got
> store=Mail::SpamAssassin::BayesStore::DBM=HASH(0x806108798)
> Jul  1 09:35:06.098 [49647] dbg: bayes: tie-ing to DB file R/O
> /var/amavis/.spamassassin/bayes_toks
> Jul  1 09:35:06.098 [49647] dbg: bayes: tie-ing to DB file R/O
> /var/amavis/.spamassassin/bayes_seen
> Jul  1 09:35:06.098 [49647] dbg: bayes: found bayes db version 3
> Jul  1 09:35:06.099 [49647] dbg: bayes: DB journal sync: last sync: 0
> Jul  1 09:35:06.570 [49647] dbg: bayes: DB journal sync: last sync: 0
> Jul  1 09:35:06.570 [49647] dbg: bayes: corpus size: nspam = 120857,
> nham = 664988
> 
> After a while the error returns. Do I have to wipe my bayes DB?

I wiped my bayes DB and learned more than 200 spam and ham messages each.
While nham and nspam were below 200 message error was gone. But now it
is back.

% spamassassin -t < OvwTlDIfJxAe
 [...]
 3.5 BAYES_99               BODY: Bayes spam probability is 99 to 100%
                            [score: 1.0000]
 [...]			    
 0.2 BAYES_999              BODY: Bayes spam probability is 99.9 to 100%
                            [score: 1.0000]
 [...]

Running the same command with the "-D" switch the error appears and I
don't see the BAYES score. There is also no BAYES score in the amavisd
log. :-(

Any ideas?

Thanks.

--
Herbert

Mime
View raw message