spamassassin-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raymond Jette <rje...@mestek.com>
Subject RE: Rules not working
Date Mon, 09 Sep 2013 01:34:32 GMT
I stoped spamd

# systemctl stop spamassassin.service

Then I ran in debug mode

# echo | spamd -D > /root/spamdDiag 2>&1

The following line shows a custom test file I created being read in

Sep  8 21:31:45.423 [10285] dbg: config: read file /etc/mail/spamassassin/a.cf

Thanks.
________________________________________
From: jdow [jdow@earthlink.net]
Sent: Sunday, September 08, 2013 9:20 PM
To: users@spamassassin.apache.org
Subject: Re: Rules not working

Have you generated said debug output by running spamd with the -D flag?
That is the debug output that matters. Also run spamassassin -D as a
bog standard user rather than root.

To minimize interruptions to mail flow I'd test it this way:

stop spamd

manually start spamd with the -D flag as well as all the other usual flags
and values.

Run tests through it using regular mail and a manual "spamc".

Stop the -D spamd.

Restart the normal spamd.

This should only take a minute or two.

{^_^}


On 2013/09/08 18:09, Raymond Jette wrote:
> Yes.  The permissions are correct.  Yes, the debug output shows that the files and rules
were found and matched against the test message.
> ________________________________________
> From: jdow [jdow@earthlink.net]
> Sent: Sunday, September 08, 2013 9:01 PM
> To: users@spamassassin.apache.org
> Subject: Re: Rules not working
>
> Did you set permissions? (-rw-r--r--)
>
> Are there any signs in the debug output that the files were even found at all?
> Whatever it is that actually calls spamd or uses spamassassin internally may
> do something to direct it off into left field.
>
> {^_^}
>
> On 2013/09/08 17:23, Raymond Jette wrote:
>> Yes.  I restarted everything.  When this did not work I rebooted the server.  This
still did not help.
>> ________________________________________
>> From: jdow [jdow@earthlink.net]
>> Sent: Sunday, September 08, 2013 8:21 PM
>> To: users@spamassassin.apache.org
>> Subject: Re: Rules not working
>>
>> On 2013/09/08 16:55, Raymond Jette wrote:
>>> When I add add custom rules to /etc/mail/spamassassin/local.cf the rules work
as expected.  If I create any *.cf file and put the rules in they do not work.  My test rule
is:
>>>
>>> body     test_match_all     /.*/
>>> score    test_match_all     -0.01
>>>
>>> Rules only work if they are in local.cf.  If I run the following command:
>>>
>>> echo | spamassassin --debug
>>>
>>> I can see my custom rules that are in files other than local.cf get called. 
Why would they work this way but never get called when spamd is called from exim?
>>>
>>> Thanks for any help you can provide,
>>> Ray
>>
>> Did you restart spamassassin or the tool that uses spamassassin itself?
>>
>> {^_^}
>>
>>
>

Mime
View raw message