spamassassin-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Warren Togami Jr." <wtog...@gmail.com>
Subject Re: sa-update failing
Date Mon, 18 Jul 2011 01:58:41 GMT
On 7/17/2011 7:55 AM, Axb wrote:
> On 2011-07-17 18:32, Warren Togami Jr. wrote:
>> On 7/16/2011 4:54 AM, darxus@chaosreigns.com wrote:
>>> On 07/15, ssapp80 wrote:
>>>> Running spamassassin-3.3.2 on CentOS 5.5
>>>> perl-Net-DNS ver 0.59 installed
>>>>
>>>> When I run sa-update i receive the following failures on the Net::DNS
>>>> module
>>>>
>>>> "name2labels" is not exported by the Net::DNS module
>>>
>>> My guess is Net::DNS version 0.59 is too old. In which case it would be
>>> nice if spamassassin specified that in its use statement so it would
>>> give a
>>> more useful error. If upgrading that perl module fixes that problem, it
>>> might be worth opening a bug to improve that error. I'm using Net::DNS
>>> v0.65.
>>>
>>
>> EL-5 has perl-Net-DNS 0.59. I've been using it in production for years
>> without issue, even with 3.3.2. This is not the droid we're looking for.
>> Move along.
>>
>> Warren
>
> unless RH has patched perl-Net-DNS 0.59, iirc, the original had some
> issues in RR.pm (going back to 2007) including some security thingie.
>
> I'd recomend using 0.63 or higher.
>
> http://pkgs.repoforge.org/perl-Net-DNS/ offers a good choice.
> (I'm using 0.66 and happy)

Looking at the changelog, it appears they did patch several bugs and a 
security issue.  All I know is I have had no issues using EL-5's 0.59 
for years now.

Warren

Mime
View raw message