spamassassin-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Micah Anderson <mi...@riseup.net>
Subject sa-learn --force-expire taking hours
Date Tue, 26 Oct 2010 14:24:53 GMT

I was investigating this morning why a number of spam messages were
coming through and found that they weren't scoring on bayes, because it
was unavailable. The database connection was working fine, but I noticed
that the nightly sa-learn --sync --force-expire had been running since
3am, which was 4 and a half hours ago:

root     26302  0.0  0.0   2440   892 ?        Ss   03:00   0:00 /bin/sh -c sa-learn --sync
--force-expire >/dev/null 2>&1
root     26305  0.0  0.0  35492  2528 ?        S    03:00   0:04 /usr/bin/perl -T -w /usr/bin/sa-learn
--sync --force-expire

I connected to the database and did a 'show processlist\g' and found a
number of really long running processes:

| Id     | User    | Host            | db    | Command | Time   | State        | Info
|  66652 | spamass | 127.0.0.1:55248 | bayes | Query   | 355113 | Sending data | SELECT count(*)
               FROM bayes_token
              WHERE id = '5'
                AND ati | 

a bunch of NULL processes (what are these?):

| 463898 | spamass | 127.0.0.1:41393 | bayes | Sleep   |  10592 |              | NULL    
                                                                                

and a handful of 'rollback' processes:

| 474169 | spamass | 127.0.0.1:35973 | bayes | Query   |   1078 | NULL         | rollback
   

Plus the various bayes processes that I expect, a sampling of which is below:

| 474756 | spamass | 127.0.0.1:34141 | bayes | Query   |    472 | end          | UPDATE bayes_token
SET atime = '1288102083' WHERE id = '5' AND token IN ('???-6','?	?,'R???','Xt | 
| 475050 | spamass | 127.0.0.1:48442 | bayes | Query   |      5 | Updating     | UPDATE bayes_vars
              SET spam_count = spam_count + '1'
             WHERE id = '5'        | 
| 475089 | spamass | 127.0.0.1:48669 | bayes | Query   |      0 | statistics   | SELECT RPAD(token,
5, ' '), spam_count, ham_count, atime
                     FROM bayes_token

Any ideas what could be going on, or steps I could take to troubleshoot
this?

Thanks!
micah

-- 


Mime
View raw message