spamassassin-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Nicholson <robert.nichol...@gmail.com>
Subject Re: X-Spam-Languages always blank?
Date Sat, 13 Feb 2010 14:49:53 GMT
I'm going thru debug with version 3.3.0 and I see it definately puts the X-Languages metadata
in place but even with the add_header line that I have it leaves X-Spam-Languages unpopulated

500:	    @matches = classify(\$body, $opts->{conf}, %skip);
  DB<2> n
Feb 13 08:30:23.876 [56907] dbg: textcat: language possibly: en
Mail::SpamAssassin::Plugin::TextCat::extract_metadata(/home/elastica/SALOCAL-3.3.0/lib/perl5/site_perl/5.8.8/Mail/SpamAssassin/Plugin/TextCat.pm:507):
507:	  undef $body;
  DB<2> x @matches
0  'en'

but all I get for this example is blank for the header value

ok looks like my problem is because I'm reprocessing a message that already has an X-Spam-Languages:
<nothing> header in it.

I expected that it wouldn't matter that it was there as it would be removed and populated
accordingly but that is only happening if I remove
the original X-Spam-Languages header from the message.

is this a bug? 

My understanding is that it should remove all X-Spam headers when reprocessing the message?


On Feb 12, 2010, at 10:48 PM, Matt Kettler wrote:

> On 2/12/2010 10:50 PM, Robert Nicholson wrote:
>> I have 
>> 
>> Feb 12 19:35:31.669 [81642] dbg: textcat: X-Languages: "en", X-Languages-Length:
424
>> 
>> in my testing
>> 
>> but the X-Spam-Languages ends up with nothing
>> 
>> I have in my user_prefs 
>> 
>> add_header all Languages _LANGUAGES_
>> 
>> 
> 
> Is the X-Spam-Languages header being added, with no text, or is not
> appearing at all?
> 
> What version of SA are you using? some versions (IIRC early 3.1.x
> members) did not support the _LANGUAGES_ meta-tag.
> 
> 


Mime
View raw message