spamassassin-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Larry Nedry <spamassas...@bluestreak.net>
Subject Re: whitelist_auth problem
Date Wed, 11 Jun 2008 17:02:08 GMT
On 6/7/08 at 3:19 PM -0500 Larry Nedry wrote:
>Hi All,
>
>A few days ago whitelist_auth and whitelist_from_dkim stopped working.
>Everything else seems to be working well.  I haven't made any changes to
>the server recently so I find this puzzling.
>
>neither of these rules work:
>    whitelist_from_dkim    *@example.com
>    whitelist_auth    *@example.com
>And it doesn't matter whether the rules are placed in local.cf or the
>userprefs MySQL table.
>
>whitelist_from and white_from_rcvd still work so I'm using those as a stop
>gap.
>
>This server is running SA 3.1.4 with compiled rules and user prefs in MySQL.
>
>Does anyone have any ideas what might have caused this to stop working?  Or
>how I could troubleshoot it?
>
>Nedry

Thanks for the reply Benny!

On 6/11/08 at 12:08 AM Benny Pedersen wrote:
>does the domain have dkim or spf ?

Yes, all of the several domains that I have whitelisted have DKIM, SPF or
DomainKeys.  Mail from these domains are properly hitting the DKIM_SIGNED
or SPF_PASS rules.

>dkim will fail if headers is modified from the signer

The headers have not been modified.  Whitelisting, using the authenticated
whitelist rules, was working fine until recently.

>what version of Mail::DKIM do you use ?
>and Mail::SPF ?

[25942] dbg: diag: module installed: Mail::DKIM, version 0.30
[25942] dbg: diag: module installed: Mail::SPF, version v2.005

Both modules are working properly.

>have you seen
>
>perldoc Mail::SpamAssassin::Conf
>perldoc Mail::SpamAssassin::Plugin::SPF
>perldoc Mail::SpamAssassin::Plugin::DKIM

Yes, I've read through them many times over the last several years.  And
recent weeks.  :-)

Both SPF and DKIM are working properly.  The authenticated whitelist rules
seem to be the only part of SA that isn't working.

>and does
>
>spamassassin 2>&1 -D --lint
>
>give any missing perl modules and or errors ?

No, there aren't any missing perl modules, errors or warnings.  I have read
every line in the debug output several times there are no indications of a
problem.

Is there anything else I can check?

Nedry


Mime
View raw message