spamassassin-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris <cpoll...@embarqmail.com>
Subject Re: Can't locate Mail/SpamAssassin/CompiledRegexps/body_0.pm in @INC (@INC
Date Fri, 06 Jun 2008 02:29:37 GMT

On Thursday 05 June 2008 8:15 pm, D Hill wrote:

> > It has never been there before. SA-Update was run at 6:11am and was
> > restarted at Jun  5 06:14:20 localhost spamassassin: spamd startup
> > succeeded
>
> Perhaps you do not have something set up right or haven't run sa-compile
> yet. Looking at my computer here running FreeBSD, I see:
>
>    %ls -l
> /var/db/spamassassin/compiled/3.002004/Mail/SpamAssassin/CompiledRegexps/
> total 58
>    -r--r--r--  1 root  wheel  55419 Mar  4 19:57 body_0.pm
>    -r--r--r--  1 root  wheel    957 Mar  4 20:00 body_500.pm
I've 'never' run sa-compile before. However, I did a test, I commented out the 

loadplugin Mail::SpamAssassin::Plugin::Rule2XSBody

line in v320.pre, stopped and started sa, and the line above went away. To 
make sure I uncommented it out, stopped and started sa and the error above 
came back. So, that takes care of that issue, don't know why I didn't see it 
before. Now if I could just get rid of this so easily:

Jun  5 21:21:29 localhost spamd[24341]: Can't locate Log/Agent.pm in @INC 
(@INC contains: 
lib /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5

/usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl

/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5

/usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4

/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3

/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1

/usr/lib/perl5/vendor_perl) at (eval 1365) line 2. 
Jun  5 21:21:29 localhost spamd[24341]: Can't locate Log/Agent.pm in @INC 
(@INC contains: 
lib /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5

/usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl

/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5

/usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4

/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3

/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1

/usr/lib/perl5/vendor_perl) at (eval 1365) line 2. 
Jun  5 21:21:29 localhost spamd[24341]: BEGIN failed--compilation aborted at 
(eval 1365) line 2. 

I've been told the above is a razor issue, I've posted the information to the 
razor-users list but have received no replies yet. As near as I can tell this 
started after the update previous to todays but I can't honestly say for 
sure.

Thanks for the help on the above, appreciate it.

--CAPoT

Mime
View raw message