spamassassin-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From carno...@nc.rr.com
Subject RE:Upgrade to 3.2
Date Wed, 04 Jul 2007 13:11:58 GMT
John D. Hardin wrote:
> On Tue, 3 Jul 2007 carnold5@nc.rr.com wrote:
> 
>> I downloaded the traball and made a rpm; which created
>> perl-spamassassin.rpm and mail-spamassassin.rpm. I installed
>> perl-spamassassin first using yast and then spamassassin using
>> yast. The spamassassin rpm failed to installed but when i do a rpm
>> -qa spamassassin it shows both 3.1 and 3.2 installed.
> 
> I assume you provided the "upgrade" option on the command line? You 
> can install multiple versions of the same package if you're not 
> careful.
> 
> This should do it:
> 
>   rpm -Uvh *spamassassin*3.2*.rpm
> 
>> I look in /etc/mail/spamassassin and all the 3.1 files are still
>> there along with 3.2pre file.
> 
> What does "spamassassin --debug --lint" say about the version? 
> 
>> Should i uninstall and then reinstall and if i do this, what will
>> happen to all the existing rules and what-not?
> 
> You should know what custom rules you've installed. They should be 
> copied somewhere safe and/or checked into revision control (learn 
> RCS. live RCS.) and should be easy to reinstall if needed.
> 
> It won't hurt to uninstall all of the SA RPMs and reinstall just the 
> latest one.
> 
> The rites of initiation continue... :)
> 
> --
>  John Hardin KA7OHZ                    http://www.impsec.org/~jhardin/
>  jhardin@impsec.org    FALaholic #11174     pgpk -a jhardin@impsec.org
>  key: 0xB8732E79 -- 2D8C 34F4 6411 F507 136C  AF76 D822 E6E6 B873 2E79
> -----------------------------------------------------------------------
>   It there a Special Olympics for terrorists going on in the UK this
>   week?                                 -- Bruce Schneier, 07/02/2007
> -----------------------------------------------------------------------
>  Tomorrow: The 231st anniversary of the Declaration of Independence
>
Wow! I have installed from source, i have installed from rpm and i have
found out that installing from cpan does not work with suse/SLES9. I
have re-downloaded the tarball and the zip file. I have rebuilt the rpm
using rpmbuild -tb <filename> and nothing is working. I have installed
from the install discs which installs Sa 2.64 and used the "upgrade"
option, when installing from rpm, i always get this:
ERROR(InstTarget:E_RpmDB_subprocess_failed)
> ---
> error: %post(spamassassin-3.2.1-1) scriptlet failed, exit status 127
> 
> 2007-07-03 21:41:52 perl-Mail-SpamAssassin.rpm installed ok
> 2007-07-03 21:43:16 spamassassin.rpm install failed
> rpm output:
> spamassassin              0:off  1:off  2:off  3:on   4:off  5:on   
> 6:off/var/tmp/rpm-tmp.97155: line 13: /sbin/service: No such file 
> or directory
> warning: waiting to reestablish exclusive database lock
> error: %post(spamassassin-3.2.1-1) scriptlet failed, exit status 127

Mime
View raw message