spamassassin-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philip Prindeville <philipp_s...@redfish-solutions.com>
Subject Re: Can't upgrade w/ RPM
Date Thu, 02 Nov 2006 19:38:55 GMT
Jim Maul wrote:

>Philip Prindeville wrote:
>  
>
>>Hi.
>>
>>I'm running FC3 on an AMD64 platform for my mail server,
>>and I had last installed SpamAssassin 3.1.5.  Well, I grabbed the
>>tarball for 3.1.7, and did a "rpmbuild -tb ..." of the tarball.
>>
>>Worked fine.
>>
>>Then I tried to upgrade via RPM:
>>
>># rpm -v -U /home/src/redhat/RPMS/x86_64/perl-Mail-SpamAssassin-3.1.7-1.x86_64.rpm
>>error: Failed dependencies:
>>        perl-Mail-SpamAssassin = 3.1.5-1 is needed by (installed) spamassassin-3.1.5-1.x86_64
>>
>>
>>any ideas why this is happening and what the fix is?
>>
>>-Philip
>> 
>>    
>>
>
>You cant just upgrade one of the RPM's, you need to do them all at once.
>
>spamassassin-3.1.5-1.x86_64 is using 
>perl-Mail-SpamAssassin-3.1.5-1.x86_64.rpm so you cant upgrade one 
>without the other.
>
>-Jim
>  
>

You're right.  Sorry, I spaced.  I figured that the RPM container
actually contained several modules, like zaptel does (it also contains
zaptel-devices, zaptel-libs, etc).

Is there any reason to not have a single container contain multiple
packages?  Since they do both need to be installed simultaneously?

-Philip


Mime
View raw message