spamassassin-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From j.@jmason.org (Justin Mason)
Subject Re: Is re2c 0.10.x really needed?
Date Mon, 28 May 2007 11:13:07 GMT

Duncan Findlay writes:
> Hey folks,
> 
> The version of re2c currently in Debian is 0.9.x, and according to the
> sa-compile man page, 0.10.x is needed for the Rule2XSBody plugin. As
> far as I can tell, sa-compile is working fine with 0.9.x. Anybody know
> the reason behind recommending 0.10.x?

I couldn't get 0.9.x to produce output when I was writing sa-compile.
0.10.x worked for me, but 0.11.x core dumps for some people: bug 5435.

The re2c author has recommended 0.12.0:

http://sourceforge.net/tracker/index.php?func=detail&aid=1708378&group_id=96864&atid=616200

  Actually i highly suggest you use cvs version of either 0.12.0
  (unreleased) or even HEAD. It appears the generated code is wrong using
  the older re2c versions. I discoverd this while fixing the crash. So in
  0.12.0 and HEAD both issues are resolved.

--j.

Mime
View raw message