spamassassin-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From j.@apache.org
Subject svn commit: r801099 - /spamassassin/trunk/Makefile.PL
Date Wed, 05 Aug 2009 09:13:55 GMT
Author: jm
Date: Wed Aug  5 09:13:54 2009
New Revision: 801099

URL: http://svn.apache.org/viewvc?rev=801099&view=rev
Log:
bug 6131: META_MERGE is a recent addition to ExtUtils::MakeMaker; don't add it if the MM version
is less than 6.46

Modified:
    spamassassin/trunk/Makefile.PL

Modified: spamassassin/trunk/Makefile.PL
URL: http://svn.apache.org/viewvc/spamassassin/trunk/Makefile.PL?rev=801099&r1=801098&r2=801099&view=diff
==============================================================================
--- spamassassin/trunk/Makefile.PL (original)
+++ spamassassin/trunk/Makefile.PL Wed Aug  5 09:13:54 2009
@@ -13,8 +13,9 @@
 # avoid stupid 'Argument "6.30_01" isn't numeric in numeric ge (>=)' warnings;
 # strip off the beta subversion noise that causes the trouble.
 $mm_version =~ s/_\S+$//;      # "6.30_01" => "6.30"
+$mm_version += 0;
 
-if ($mm_version+0 < 6.17) {
+if ($mm_version < 6.17) {
   die "SpamAssassin Makefile.PL requires at least ExtUtils::MakeMaker v6.17";
 }
 
@@ -322,7 +323,8 @@
 
 #######################################################################
 
-$makefile{META_MERGE} = {
+# bug 6131
+($mm_version >= 6.46) and $makefile{META_MERGE} = {
   license => 'apache',
 
   resources => {
@@ -361,7 +363,7 @@
 $makefile{EXE_FILES} = [ values %{$makefile{EXE_FILES}} ];
 $makefile{AUTHOR} =~ s/(<.+) at (.+>)/$1\@$2/;
 WriteMakefile(%makefile);
-print "Makefile written by ExtUtils::MakeMaker ${mm_version}\n";
+print "Makefile written by ExtUtils::MakeMaker $mm_version\n";
 
 #######################################################################
 



Mime
View raw message