spamassassin-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mmarti...@apache.org
Subject svn commit: r791657 - in /spamassassin/trunk/lib/Mail/SpamAssassin: Plugin/DKIM.pm Util/DependencyInfo.pm
Date Tue, 07 Jul 2009 00:14:08 GMT
Author: mmartinec
Date: Tue Jul  7 00:14:07 2009
New Revision: 791657

URL: http://svn.apache.org/viewvc?rev=791657&view=rev
Log:
Bug 6100, DependencyInfo.pm, DKIM.pm: bump the required
minimal version of Mail::DKIM to 0.31 (warn otherwise, but
not enforced). Updated associated text in DependencyInfo. 

Modified:
    spamassassin/trunk/lib/Mail/SpamAssassin/Plugin/DKIM.pm
    spamassassin/trunk/lib/Mail/SpamAssassin/Util/DependencyInfo.pm

Modified: spamassassin/trunk/lib/Mail/SpamAssassin/Plugin/DKIM.pm
URL: http://svn.apache.org/viewvc/spamassassin/trunk/lib/Mail/SpamAssassin/Plugin/DKIM.pm?rev=791657&r1=791656&r2=791657&view=diff
==============================================================================
--- spamassassin/trunk/lib/Mail/SpamAssassin/Plugin/DKIM.pm (original)
+++ spamassassin/trunk/lib/Mail/SpamAssassin/Plugin/DKIM.pm Tue Jul  7 00:14:07 2009
@@ -506,8 +506,13 @@
   };
 
   if (!defined($eval_stat)) {
-    dbg("dkim: using Mail::DKIM version %s for DKIM checks",
-        Mail::DKIM::Verifier->VERSION);
+    my $version = Mail::DKIM::Verifier->VERSION;
+    if ($version >= 0.31) {
+      dbg("dkim: using Mail::DKIM version $version for DKIM checks");
+    } else {
+      warn("dkim: Mail::DKIM $version is older than the required ".
+           "minimal version 0.31, suggested upgrade to 0.35 or later!\n");
+    }
     $self->{tried_loading} = 1;
   } else {
     dbg("dkim: cannot load Mail::DKIM module, DKIM checks disabled: $eval_stat");

Modified: spamassassin/trunk/lib/Mail/SpamAssassin/Util/DependencyInfo.pm
URL: http://svn.apache.org/viewvc/spamassassin/trunk/lib/Mail/SpamAssassin/Util/DependencyInfo.pm?rev=791657&r1=791656&r2=791657&view=diff
==============================================================================
--- spamassassin/trunk/lib/Mail/SpamAssassin/Util/DependencyInfo.pm (original)
+++ spamassassin/trunk/lib/Mail/SpamAssassin/Util/DependencyInfo.pm Tue Jul  7 00:14:07 2009
@@ -143,10 +143,12 @@
 },
 {
   module => 'Mail::DKIM',
-  version => '0.28',
+  version => '0.31',
   desc => 'If this module is installed, and you enable the DKIM plugin,
-  SpamAssassin will perform DKIM lookups when a DKIM-Signature
-  header is present in the message headers.'
+  SpamAssassin will perform DKIM signature verification when DKIM-Signature
+  header fields are present in the message headers, and check ADSP rules
+  when a mail message does not contain a valid author domain signature.
+  Version 0.35 or later is recommended.'
 },
 {
   module => 'DBI',



Mime
View raw message