sling-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felix Meschberger <fmesc...@adobe.com>
Subject Re: Component Configuration troubles
Date Thu, 23 Feb 2012 10:39:13 GMT
Hi,

Am 22.02.2012 um 18:48 schrieb Markus Joschko:

> Hi,
> I have an issue with the configuration for a component. I can
> configure the component perfectly fine through the web console
> configuration.
> I see that the configuration is written in
> /apps/sling/config/foo.bar.config and the jcr:data property has the
> correct value.
> 
> However when I restart launchpad, the configuration admin shows me an
> empty dialog and states: "Unbound or new configuration"

Looks like the consumer bundle is not active, which provides the meta type description (which
is the reason for the empty dialg (empty meaning no fields, right?)) [Side note: If you update
the web console to the latest trunk build you might be able to see the fields derived from
the actual property values]. 
 
In addition it looks like the configuration is not really assigned to a component (which is
was the "Unbound or new configuration" says).

Regards
Felix

> 
> The configuration in the repository is still there but it is obviously
> not picked up.
> I changed some other components configuration and this worked
> perfectly fine. However the configuration of this component is not
> written in the repository but directly below
> the sling/felix/config directory in the filesystem.
> 
> I have no idea what makes the one component special. And I also have
> no idea how to provide a more meaningful failure description.
> There are no errors or whatever in the log.
> 
> Any idea where to start? Why is one configuration stored in the
> filesystem and one in the sling repo?
> 
> 
> Thanks,
> Markus


Mime
View raw message