sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cris Rockwell (Jira)" <j...@apache.org>
Subject [jira] [Commented] (SLING-9545) Distribution Core bundle with Java 11
Date Wed, 24 Jun 2020 12:43:00 GMT

    [ https://issues.apache.org/jira/browse/SLING-9545?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17143812#comment-17143812
] 

Cris Rockwell commented on SLING-9545:
--------------------------------------

When you docs https://cwiki.apache.org/confluence/display/SLING/Java+version+support has the
statement, but the bundle only works with Java 8.

"Sling currently supports the following releases of Java
8, as it is a version that many are currently using as a basline
11, as it is the most recent version for which Oracle provides Long-Term Support"




> Distribution Core bundle with Java 11
> -------------------------------------
>
>                 Key: SLING-9545
>                 URL: https://issues.apache.org/jira/browse/SLING-9545
>             Project: Sling
>          Issue Type: Bug
>          Components: Content Distribution
>    Affects Versions: Content Distribution Core 0.3.4, Content Distribution Core 0.4.2
>            Reporter: Cris Rockwell
>            Priority: Major
>         Attachments: Screen Shot 2020-06-24 at 8.09.38 AM.png, Screen Shot 2020-06-24
at 8.38.26 AM.png
>
>
> Apache Sling Distribution Core (org.apache.sling.distribution.core) bundle does not activate
on Sling12 using Java 11
> https://github.com/apache/sling-org-apache-sling-distribution-core
> {{mvn clean install}} results in the error below
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-antrun-plugin:1.8:run (set-bundle-required-execution-environment)
on project org.apache.sling.distribution.core: An Ant BuildException has occured: Unable to
create javax script engine for javascript
> [ERROR] around Ant part ...<script language="javascript">var System = java.lang.System;...
@ 4:33 in /Users/cmrockwe/Documents/a3workspace/sling-org-apache-sling-distribution-core/target/antrun/build-main.xml
> Similar issue as described here
> https://stackoverflow.com/questions/43067454/ant-running-from-maven-antrun-plugin-cant-find-scripting-engine-on-java-9



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message