sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bertrand Delacretaz <bdelacre...@apache.org>
Subject Re: [VOTE] Release Apache Sling Dynamic Include 3.2.0
Date Mon, 22 Jun 2020 10:40:03 GMT
On Thu, Jun 18, 2020 at 1:37 PM Robert Munteanu <rombert@apache.org> wrote:
> ...Staging repository:
> https://repository.apache.org/content/repositories/orgapachesling-2283/ ..

I'm getting an error from the maven baseline plugin when trying to
build this from
org.apache.sling.dynamic-include-3.2.0-source-release.zip

[WARNING] Could not transfer metadata
org.apache.sling:org.apache.sling.dynamic-include/maven-metadata.xml
from/to apache.releases.https
(https://repository.apache.org/service/local/staging/deploy/maven2):
Failed to transfer file
https://repository.apache.org/service/local/staging/deploy/maven2/org/apache/sling/org.apache.sling.dynamic-include/maven-metadata.xml
with status code 400
[INFO] The baseline version was found to be 3.1.6
[ERROR] The bundle version change (3.1.6 to 3.2.0) is too low, the new
version must be at least 4.0.0
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time:  5.626 s
[INFO] Finished at: 2020-06-22T12:37:22+02:00
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal
biz.aQute.bnd:bnd-baseline-maven-plugin:4.2.0:baseline (bnd-baseline)
on project org.apache.sling.dynamic-include: An error occurred while
calculating the baseline: The baselining plugin detected versioning
errors -> [Help 1]

Am I doing something wrong?

-Bertrand

Mime
View raw message