sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Pauls (Jira)" <j...@apache.org>
Subject [jira] [Commented] (SLING-9425) Analyser fails when bundle requires Java 11
Date Wed, 06 May 2020 10:31:00 GMT

    [ https://issues.apache.org/jira/browse/SLING-9425?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17100656#comment-17100656
] 

Karl Pauls commented on SLING-9425:
-----------------------------------

[~rombert], well, you are overriding so it needs to be correct - I guess the problem is that
you didn't type the list so it ends-up matching strings. Try with:
{code:java}
org.osgi.framework.system.capabilities": "osgi.ee; osgi.ee=\"JavaSE\";version:List<Version>=\"1.0,1.1,1.2,1.3,1.4,1.5,1.6,1.7,1.8,9,10,11\"
{code}
 

> Analyser fails when bundle requires Java 11
> -------------------------------------------
>
>                 Key: SLING-9425
>                 URL: https://issues.apache.org/jira/browse/SLING-9425
>             Project: Sling
>          Issue Type: Bug
>          Components: Feature Model Analyser
>            Reporter: Robert Munteanu
>            Priority: Major
>
> I am trying to build an app with the feature model and Java 11. The app is a a single
project which produces the bundle and the feature model.
> When building the app the analyser fails with 
> {noformat}[ERROR] Artifact FOO requires [FOO] osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=11))"
in start level 0 but no artifact is providing a matching capability in this start level.{noformat}
> I was able to cheat my way out of this by providing a static capability for the framework:
> {noformat}org.osgi.framework.system.capabilities": "osgi.ee; osgi.ee=\"JavaSE\";version:List=\"1.0,1.1,1.2,1.3,1.4,1.5,1.6,1.7,1.8,9,10,11\"{noformat}
> but there should be better ways.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message