sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Radu Cotescu (Jira)" <j...@apache.org>
Subject [jira] [Updated] (SLING-9343) Versions of o.a.s.scripting.sightly bundles different from artifact versions
Date Thu, 09 Apr 2020 20:10:00 GMT

     [ https://issues.apache.org/jira/browse/SLING-9343?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Radu Cotescu updated SLING-9343:
--------------------------------
    Affects Version/s: Scripting HTL Compiler 1.2.0-1.4.0

> Versions of o.a.s.scripting.sightly bundles different from artifact versions
> ----------------------------------------------------------------------------
>
>                 Key: SLING-9343
>                 URL: https://issues.apache.org/jira/browse/SLING-9343
>             Project: Sling
>          Issue Type: Bug
>          Components: Scripting
>    Affects Versions: Scripting HTL Compiler 1.2.0-1.4.0, Scripting HTL Engine 1.2.0-1.4.0
>            Reporter: Stefan Seifert
>            Assignee: Radu Cotescu
>            Priority: Critical
>             Fix For: Scripting HTL Engine 1.4.0-1.4.0
>
>
> i've noticed that since the switch to the bnd-maven-plugin the bundle versions of the
scripting slightly bundles are transformed in a way that does no longer match with the artifact
version.
> example for [org.apache.sling.scripting.sightly|https://repo1.maven.org/maven2/org/apache/sling/org.apache.sling.scripting.sightly/]:
> {noformat}
> 1.1.0-1.4.0 -> 1.1.0.1_4_0
> 1.1.2-1.4.0 -> 1.1.2.1_4_0
> 1.2.0-1.4.0 -> 1.2.0.0      -> this was the switch to bnd-maven-plugin
> 1.3.0-1.4.0 -> 1.3.0.0
> 1.3.2-1.4.0 -> 1.3.2.0
> {noformat}



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message