sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Radu Cotescu (Jira)" <j...@apache.org>
Subject [jira] [Created] (SLING-9048) The HTL engine does not specify the correct io.sightly.runtime requirement version range
Date Wed, 05 Feb 2020 13:40:00 GMT
Radu Cotescu created SLING-9048:
-----------------------------------

             Summary: The HTL engine does not specify the correct io.sightly.runtime requirement
version range
                 Key: SLING-9048
                 URL: https://issues.apache.org/jira/browse/SLING-9048
             Project: Sling
          Issue Type: Bug
          Components: Scripting
    Affects Versions: Scripting HTL Engine 1.2.0-1.4.0
            Reporter: Radu Cotescu
             Fix For: Scripting HTL Engine 1.3.4-1.4.0


When SLING-8471 was implemented, the transition from the {{maven-bundle-plugin}} to the {{bnd-maven-plugin}}
introduced the error of defining the {{io.sightly.runtime}} requirement as:
{code:java}
Require-Capability: io.sightly.runtime; filter:="(&(version<=1.0)(!(version>=2.0)))"
{code}
instead of:
{code:java}
Require-Capability: io.sightly.runtime; filter:="(&(version>=1.0)(!(version>=2.0)))"
{code}

While in practice this doesn't affect a regular Sling setup, it should be corrected.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message