sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konrad Windszus (Jira)" <j...@apache.org>
Subject [jira] [Commented] (SLING-8950) Make compatible with JSON-P 1.1
Date Sun, 22 Dec 2019 12:32:00 GMT

    [ https://issues.apache.org/jira/browse/SLING-8950?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17001917#comment-17001917
] 

Konrad Windszus commented on SLING-8950:
----------------------------------------

Sorry for the noise, actually the bundle is already supporting alll JSON-P 1.1 methods. The
UnsupportedOperationException is even in the original source (https://github.com/eclipse-ee4j/jsonp/blob/master/api/src/main/java/jakarta/json/spi/JsonProvider.java)
and is just for ensuring backwards compatibility with 1.0 providers.

> Make compatible with JSON-P 1.1
> -------------------------------
>
>                 Key: SLING-8950
>                 URL: https://issues.apache.org/jira/browse/SLING-8950
>             Project: Sling
>          Issue Type: Improvement
>          Components: Commons
>    Affects Versions: Commons Johnzon 1.1.2
>            Reporter: Konrad Windszus
>            Priority: Minor
>             Fix For: Commons Johnzon 1.1.4
>
>
> Currently the provider at https://github.com/apache/sling-org-apache-sling-commons-johnzon/blob/master/src/main/java/javax/json/spi/JsonProvider.java
throws UnsupportedOperationException for all methods being added with JSON-P 1.1. According
to  https://johnzon.apache.org/download.html every Johnzon 1.1.x release should implement
JSON-P 1.1 though.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message