sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carsten Ziegeler <cziege...@apache.org>
Subject Re: [feature] Analyser complains that 'Bundle contains classes in the default package'
Date Fri, 08 Nov 2019 13:18:52 GMT
Hi

it seems you run with all available checks. You should only run api 
region checks if you use api regions. We recently moved all analysers 
that use api regions to the regions extension.

The other check is done by the analyser for OSGi connect; I can't recall 
why this check was useful though.

Regards
Carsten

Am 08.11.2019 um 12:50 schrieb Robert Munteanu:
> Hi,
> 
> I'm build an application using the feature model tooling. I enabled
> analysers and got shout at by the 'api-regions-check-order' checker
> since it required configuration. I don't use API regions, so I disabled
> that.
> 
> Then I ran into a problem due to jackson jar having classes in the
> default package:
> 
>    Bundle contains classes in the default package: Artifact
> [id=com.fasterxml.jackson.core:jackson-core:2.10.0]
> 
> I will disable this check as well, but I would like to understand why
> this is a problem.
> 
> Thanks,
> Robert
> 

-- 
--
Carsten Ziegeler
Adobe Research Switzerland
cziegeler@apache.org

Mime
View raw message