sling-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Ziegeler (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SLING-8417) Review Feature Analyser and IO imports
Date Fri, 07 Jun 2019 11:29:00 GMT

    [ https://issues.apache.org/jira/browse/SLING-8417?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16858525#comment-16858525
] 

Carsten Ziegeler commented on SLING-8417:
-----------------------------------------

The imports / exports of feature IO
{noformat}
  javax.json                             {version=[1.0,2)}
  javax.json.stream                      {version=[1.0,2)}
  org.apache.johnzon.core
  org.apache.sling.feature               {version=[0.2,1)}
  org.apache.sling.feature.io.file.spi   {version=[0.1,1)}
  org.osgi.framework                     {version=[1.8,2)}
  org.osgi.resource                      {version=[1.0,2)}
  org.osgi.util.converter                {version=[1.0,2)}
  org.slf4j                              {version=[1.7,2)}
Export-Package
  org.apache.sling.feature.io            {version=0.1.0}
  org.apache.sling.feature.io.file       {version=0.1.0}
  org.apache.sling.feature.io.file.spi   {version=0.1.0, imported-as=[0.1,1)}
  org.apache.sling.feature.io.json       {version=0.1.0}
{noformat}

> Review Feature Analyser and IO imports
> --------------------------------------
>
>                 Key: SLING-8417
>                 URL: https://issues.apache.org/jira/browse/SLING-8417
>             Project: Sling
>          Issue Type: Bug
>          Components: Feature Model
>    Affects Versions: Feature Model IO 1.0.2, Feature Model Analyser 1.0.2
>            Reporter: David Bosschaert
>            Priority: Major
>             Fix For: Feature Model IO 1.0.4, Feature Model Analyser 1.0.4
>
>
> As reported by [~klcodanr]: 
> Do you expect these bundles to start in a vanilla Sling instance? I checked
> the latest snapshot and it failed to start due to the following missing
> dependencies:
> Failed to start org.apache.sling.feature.analyser, current state: Installed
> Imports in error state:
> ERROR: org.apache.commons.text,version=[1.6,2) -- Cannot be resolved
> ERROR: org.apache.commons.text.lookup,version=[1.6,2) -- Cannot be resolved
> Failed to start org.apache.sling.feature.io, current state: Installed
> Imports in error state:
> ERROR: org.apache.johnzon.core -- Cannot be resolved
> ERROR: org.osgi.util.converter,version=[1.0,2) -- Cannot be resolved
>  
> Response from [~cziegeler]:
> I think it's fine if these modules require additional bundles like 
> commons text or the converter to be installed.
> The only one that worries me is the johnzon import. We should look at it 
> for the next release. We can continue with this release as the main 
> usage of most of these modules is in tooling at build time atm.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message